Uncaught SyntaxError: Unexpected token export - popper.js error

Angular is giving the error: popper.js in bootstrap 4 gives SyntaxError Unexpected token export

I'm getting this error from browser console.

Even I changed the popper.min.js location reference but no use..

node_modules/popper.js/dist/umd/popper.min.js

node_modules/popper.js/dist/ems/popper.min.js

Angular.json

    "scripts": [
      "node_modules/bootstrap/dist/js/bootstrap.min.js",
      "node_modules/jquery/dist/jquery.slim.min.js",
      "node_modules/popper.js/dist/popper.min.js"
    ]

Answers:

Answer

Bootstrap.min.js is depend on the popper.min.js , change the order as follows,

   "scripts": [
     "node_modules/jquery/dist/jquery.slim.min.js",
     "node_modules/popper.js/dist/popper.min.js",
      "node_modules/bootstrap/dist/js/bootstrap.min.js",
   ]

Tags

Recent Questions

Top Questions

Home Tags Terms of Service Privacy Policy DMCA Contact Us Javascript

©2020 All rights reserved.