'Range.detach' is now a no-op, as per DOM

I have been noticing this warning and error message in my console after updating Chrome to 36.0.1985.125.

Warning:

'Range.detach' is now a no-op, as per DOM (http://dom.spec.whatwg.org/#dom-range-detach). 

Error:

Discontiguous selection is not supported.

Can be seen: http://rangy.googlecode.com/svn/trunk/demos/cssclassapplier.html

Other javascript/jquery plugins (wysihtml5, rangy) have also been affected, any solutions?

Answers:

Answer

I'm still trying to decide what to do about this. See this Rangy issue (migration to GitHub not quite complete, sorry). I think it's unhelpful behaviour on the part of Chrome and would like it removed.

The offending code in Rangy is in a feature test that determines whether the browser supports multiple ranges within a selection (of the current mainstream browsers, only Firefox does). Since this doesn't seem to be going away I think I'm going to have to suck it up and add a browser sniff, which makes me sad.

Update

I added a horrible browser sniff to Rangy and the error no longer appears.

Tags

Recent Questions

Top Questions

Home Tags Terms of Service Privacy Policy DMCA Contact Us Javascript

©2020 All rights reserved.